Getting the digital I/Os to work using SCPI Commands

Just about everything about Red Pitaya
Post Reply
Redp
Posts: 2
Joined: Wed Mar 01, 2017 12:55 pm

Getting the digital I/Os to work using SCPI Commands

Post by Redp » Wed Mar 01, 2017 1:02 pm

these are the SCPI commands i am using
DIG:PIN:DIR OUT,DIO0_N
DIG:PIN DIO0_N,1
i assume this would set the pin state to 1
DIG:PIN? DIO0_N
when i query it returns 0
I wonder if i missing something and if i have to write/read the FPGA registers how would start that?
please help thank you :D

Nils Roos
Posts: 1441
Joined: Sat Jun 07, 2014 12:49 pm
Location: Königswinter

Re: Getting the digital I/Os to work using SCPI Commands

Post by Nils Roos » Sun Mar 05, 2017 11:25 pm

When I use these commands on a recent RP OS release, they work as expected. You are not missing something. What RP OS version are you running?
All in a day's work for Bicycle Repair Man

Redp
Posts: 2
Joined: Wed Mar 01, 2017 12:55 pm

Re: Getting the digital I/Os to work using SCPI Commands

Post by Redp » Mon Mar 06, 2017 12:14 am

hi thanks for the reply i am using 0.96.86

Park34
Posts: 1
Joined: Mon Oct 10, 2016 2:54 pm

Re: Getting the digital I/Os to work using SCPI Commands

Post by Park34 » Tue Mar 07, 2017 3:36 pm

After updating it worked, thank you for the help. Just wont work with my circuit now haha, but that is a different issue.

Post Reply
jadalnie klasyczne ekskluzywne meble wypoczynkowe do salonu ekskluzywne meble tapicerowane ekskluzywne meble do sypialni ekskluzywne meble włoskie

Who is online

Users browsing this forum: No registered users and 4 guests