Placement, modules, components and accessories; the ones that exist and the the nice-to-be's
#8028 by hvanmunster@gmail.com
Fri Oct 06, 2017 8:29 pm
Hello,
I upgraded my RP Stemlab 125-14 from 0.97-336 to 0.98-617 (latest stable) using the iso I found on the official website. After the upgrade, I noticed that the wifi dongle is not recognized anymore. The system page/network manager displays the message 'wifi dongle not connected'.
The dongle (type:802.11n) is however physically connected and was working fine with the previous OS. I also tried a 2nd wifi dongle (Edimax): this dongle too is not recognized by the RP)

Can anyone please advice how I can get my dongle up and running again using the latest stable OS?

Thanks.
Herman Vanmunster
#8037 by hvanmunster@gmail.com
Mon Oct 09, 2017 10:21 pm
Hi,

thanks for your reply.
The problem started by putting the latest stable release on the sd-card.
I could try putting the old release back to see if I can get the wifi running again (in order to determine that the problem is indeed caused by the upgrade), but anyway I would like to use the latest release anyhow.

shutdown - wait > 1 min - reboot did not help.

Any other suggestions?
Best regards,
Herman.
#8046 by hvanmunster@gmail.com
Sun Oct 15, 2017 8:42 pm
Hi,
thanks a lot for the link to the network-setup page!
The files 'hostapd.conf' and 'wpa_supplicant.conf' are missing. According to the documentation, the wifi function can not work if both files are missing.
I tried to create them manually by following the steps that are descrbed, but without success.

I will retry once more to contact the supporline. Unfortunatly I did not get any response the first time I tried to contact them.

Best regards,
Herman.
#8055 by hvanmunster@gmail.com
Tue Oct 17, 2017 9:17 pm
Hi,

when I put the original Wifi modem, I get:
Bus 001 Device 002: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

when I put the edimax , I get:
Bus 001 Device 002: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

both of them are giving 'wifi dongle not connected' status in the webinterface (system/network manager)
Best regards,
Herman.
#8056 by HD13
Wed Oct 18, 2017 6:11 pm
Did you disconnect the ethernet (RJ45) cable ?

Because if Wifi dongle and ethernet cable are connected both it won't work.
Don't ask me how I know :D

Also check on your router if RP is connected whit Wifi or connect it whit ethernet cable
#8084 by hvanmunster@gmail.com
Thu Oct 19, 2017 8:31 pm
Hi,

disconnecting wired eth did not work. I still can't reach the WIfi connection.
Before the upgrade, both connections did work simultaneously. I used the wired connection for visualisation of the applications (scope, spectrum analyser etc) on my PC.
At the same time I used the wifi connection to acces the 'bazaar' and online documentation.

Wifi does not work anymore since the upgrade, so I have now 'shared' the wired LAN connection with the wifi connection of my PC.
RP can now access the bazaar and documentation via my PC's wireless connection.

Unfortunatly I can not access the RP via tablet or smartphone because of the wifi-problem.
Best regards,
Herman.
#8111 by JohnnyMalaria
Fri Oct 20, 2017 12:11 am
Are you by any chance trying to access your WiFi via a repeater network?

I found that both of my RPs refused to connect to my WiFi via a repeater but were fine with the network being broadcast by the modem. My 10 or so other WiFi devices have no problem whatsoever doing this. Because the modem is in a different building, I had to run a 50ft Ethernet cable and use an Ethernet switch to connect my RPs to the ports on the repeater.

Most strangely, I also had a colleague's RP which worked just fine under the same circumstances with the same SD card image etc. There was one difference: my RP is Version 1.0, his is 1.1, even though he bought his 6 months before I bought mine.

Who is online

Users browsing this forum: Google [Bot] and 1 guest