Placement, modules, components and accessories; the ones that exist and the the nice-to-be's
#1553 by kavilshah
Wed Feb 18, 2015 6:15 am
Oops sorry...!!
and there was may be software error..
problems is solved..
and again sorry for inconveniency...
#1583 by kavilshah
Tue Feb 24, 2015 9:48 am
[attachment=0]error after acquire modifiacation.png

hey... again in problem..
here i have attached my errors...

what i have done is..
1)i have modified acquire.c..(trigger source = external andtrigger mode = normal),press build button and the binary file is created.. which is copied to the bin folder of the red pitaya. and aftee that signals are given to the redpitaya and by putty command(acquire utility) tried to acquire signal and i got this error (attached as 1).

2)after building up the project debug as 1 launch on hardware GDB i got the new problem..which is attached as 2.

can you please give me any help...
You do not have the required permissions to view the files attached to this post.
#1588 by Nils Roos
Tue Feb 24, 2015 9:33 pm
There is only one attachment to your post, which one is that ?
The output looks a lot like you are trying to run a textfile with a symbol table instead of an elf binary.

I have sent you a PM about how to proceed.
#1592 by kavilshah
Wed Feb 25, 2015 5:42 am
after debug.. 2 the error occurred hardware project missing " hardware project 'referenced by a launch configuration 'acquire(2)' doesn't exist in the work space "
You do not have the required permissions to view the files attached to this post.
#1596 by kavilshah
Thu Feb 26, 2015 9:27 am

Finally done...
I Got my result... i can modify the acquire program and i can find my binary which is copied to the bin folder of redpitaya...

Thank you so much Nils for the support....Thank you,.... :) :) :) :) :) :) :)
#1722 by kcs
Wed Mar 18, 2015 12:15 pm

After changing the trigger source and trigger mode single event triggering is possible...and is very much useful.....
but for multiple trigger what should i have to do???
please provide some information regarding this...
#1730 by Nils Roos
Thu Mar 19, 2015 9:42 pm
Well, obviously you'd either build a loop into your modified acquire or write a small shell script that calls acquire repeatedly.

If you are programming the loop into the acquire code, you would probably need to rearm the scope by writing 1 to bit 0 in scope register 0x0. You may also need to set the trigger configuration again. I guess calling acquire from a loop in a script is the easier option.
#1732 by Arnold
Fri Mar 20, 2015 2:21 pm

i have some question to the develop environment...

is xilinx SDK officially supported by Redpitaya, which version? Did someone create a project template?
I need some configuration files to run an C/C++ application on the arm core0 (linux) or core1 (bare-metal) ...

Vivado Design Suite is only required for the FPGA, which verison do you support?

#1736 by Nils Roos
Fri Mar 20, 2015 2:52 pm
Vivado + SDK 2013.3 is the recommended version for Red Pitaya development.

I see you already found this thread. For a bare metal application, you would of course use "standalone" in the OS setting instead of linux.

Who is online

Users browsing this forum: No registered users and 2 guests