Page 8 of 9

Re: Antenna analyser

Posted: Tue Sep 19, 2017 2:19 pm
by Drachenfrucht
What a pity :o Now I really regret that I formatted my SDcard. :(

1.) I didn't know the VNAserver is running, so I tried connect to it. I can connect, but the sweep FAILS, NO RESPONSE. Sometimes it seems that it crashed my RedPitaya after I clicked "DUT" button on vna-client. The network connection broke, ping failed, I had to reboot the RedPitaya. In any case, I am not able to make a SWEEP any more.
EDIT : SOLVED after I updated the vna client, too. I just pulled the latest git content and it works as explained by Pavel in his instructions.

@Pavel: You should add the information on your ALPINE work that the HOTSPOT has IP address 192.168.42.1 ;) Thank you in advance

To everone -> Is there anyone willing to share the content of his SDcard which has the official RedPitaya ECOsystem installed (I don't care if it's version 0.95 or later) and which includes the usual applications "Oscilloscope", "SpectrumAnalyzer", "Generator" as well as some of Pavels' applications like "VNA", "SDR receiver", "SDR transceiver", "Cable Measurement", etc... ? I really regret that I did not make a 1:1 backup/image of my SDcard before I wiped it and updated to latest RedPitaya ecosystem 0.98 :( I would really appreciate such a working image file. You can simply create a 1:1 image/copy of your SDcard content by following Linux command:

Code: Select all

dd if=/dev/sdX of=/home/foo/redpitaya_backup.img bs=1M
whereas "X" should represent your SDcard device /dev/sdX and "/home/foo/redpitaya_backup.img" should be the filename you want to save the image to.

Thanks to anyone in advance.

Re: Antenna analyser

Posted: Tue Sep 19, 2017 3:32 pm
by pavel
Deleted since not relevant anymore.

Re: Antenna analyser

Posted: Tue Sep 19, 2017 3:46 pm
by Drachenfrucht
Hi Pavel,

sorry, I was confused and not sure if understood correctly that's why I bothered you with these question. I have edited my last post.

Summary:

ALPINE seems to work fine so far as I see. But please drop a note here as soon you can update/upload your applications to the RedPitaya Bazaar/Marketplace again.

Thanks for your patience and your assistance.

Re: Antenna analyser

Posted: Tue Sep 19, 2017 4:11 pm
by pavel
I have edited my last post.
Thanks!
You should add the information on your ALPINE work that the HOTSPOT has IP address 192.168.42.1
Done, I've added more information about the IP address and hostnames to my notes.

Re: Antenna analyser

Posted: Tue Sep 19, 2017 4:14 pm
by Drachenfrucht
Again, THANK YOU Pavel, for your effort and your comments.

Re: Antenna analyser

Posted: Wed Sep 27, 2017 1:52 pm
by pschroth
Hi I just installed the latest image on the hamlab. The Vector Network Analyzer does not work. I pull the latest source for the vna program from github. I use ubuntu.
I tried the same under win10 and also without succes.

Please advice

gr,

Philip

Re: Antenna analyser

Posted: Wed Sep 27, 2017 9:33 pm
by pavel
pschroth wrote:I just installed the latest image on the hamlab. The Vector Network Analyzer does not work.
Could you please provide more details? The more, the better. From your description I don't understand what is your setup, what image you're using and what exactly isn't working.

Re: Antenna analyser

Posted: Sun Oct 01, 2017 4:25 pm
by pschroth
Hi Pavel,

thanks for your reply. I will try to explain my findings.
A week ago I update my hamlab 80-10 10W to software version 0.97-166
I tried the Vector Network Analyzer program who is included in the 0.96-166 version
of the software for the Hamlab.

I downloaded the accompanion vna.py program for the linux-PC from Github.
The program connects to the hamlab, but when I try to calibrate the small window
with the sweep status stays there forever without any progress.

I tried the same from a windows computer with the same results.

I hope you have any clue what is wrong.

gr,

Philip

Re: Antenna analyser

Posted: Mon Oct 02, 2017 7:03 am
by pavel
pschroth wrote: I tried the Vector Network Analyzer program who is included in the 0.96-166 version
of the software for the Hamlab.

I downloaded the accompanion vna.py program for the linux-PC from Github.
The program connects to the hamlab, but when I try to calibrate the small window
with the sweep status stays there forever without any progress.

I tried the same from a windows computer with the same results.
Hi Philip,

Thank you for the details about your problem.

I'd suspect that the VNA application included in the Hamlab software is outdated and incompatible with the latest version of vna.py.

In August, I've changed the format of the data that the VNA server sends to the VNA client. Here is a link to the corresponding commit:

https://github.com/pavel-demin/red-pita ... 431fccdf15

To solve the problem, I'd suggest to install the latest version of the VNA application for Red Pitaya. Since the application marketplace is still broken and I can't upload my applications to it, here is a link to a .zip file that can be manually installed by unzipping it to /opt/redpitaya/www/apps:

https://www.dropbox.com/sh/5fy49wae6xwx ... 2.zip?dl=1

Over this weekend, I've fixed a couple of bugs in the VNA code. So, you'll also need to update your copy of vna.py.

Best regards,

Pavel

Re: Antenna analyser

Posted: Mon Oct 02, 2017 10:57 am
by pschroth
Hi Pavel,

Thanks for the reply. After install the zipfile manually everything works as expected.

Again thanks for your wonderfull program and support.

73's Philip PA3DFN

...-.-