Errors when cloning git into 'RedPitaya'

Applications, development tools, FPGA, C, WEB
Post Reply
max paper
Posts: 7
Joined: Mon Mar 13, 2017 5:39 am

Errors when cloning git into 'RedPitaya'

Post by max paper » Tue May 16, 2017 1:05 pm

I'm trying to run some C applications. I successfully accessed the board but was quickly stopped by an error when cloning the git:

Cloning into 'RedPitaya'...
fatal: unable to access '': Could not resolve host:

I was thinking cloning the git "manually" but it is only a temporary solution and I don't know where the file should be put...

Any experience with this kind of error?

(I have no issue to connect to the board).



Posts: 1
Joined: Wed Apr 29, 2020 7:34 am

Re: Errors when cloning git into 'RedPitaya'

Post by jlsdq » Thu Jul 23, 2020 7:48 am


Did you find a solution ?
Could be interessted too :)

Many Thanks

Posts: 12
Joined: Mon Jan 27, 2020 1:10 pm

Re: Errors when cloning git into 'RedPitaya'

Post by omereis » Thu Jul 23, 2020 8:43 am

The following worked for me both on Windows and on Ubuntu:

Code: Select all

$ mkdir <my_rp_dir>
$ cd  <my_rp_dir>
$ git clone .
Note: It's easy t miss the dot at the end of the statement. It worked for me without it, though.

Make sure you have write permissions, for example by executing

Code: Select all

touch 2.del
. If you are trying this on the Red Pitaya Card, you ma want to run

Code: Select all

$ rw
to enable writing authorization.

Hope it helps

Posts: 1
Joined: Mon Jul 27, 2020 2:27 pm

Re: Errors when cloning git into 'RedPitaya'

Post by kevin.falque » Mon Jul 27, 2020 3:19 pm

Hi everyone,
I also face problems when I want to clone into RedPitaya.

I follow the instructions on the Red Pitaya site. And i get the error message
"fatal: unable to access '': Could not resolve host:".

Any reply on this posts could help.
Thanks a lot.


Post Reply
jadalnie klasyczne ekskluzywne meble wypoczynkowe do salonu ekskluzywne meble tapicerowane ekskluzywne meble do sypialni ekskluzywne meble włoskie

Who is online

Users browsing this forum: No registered users and 1 guest