Page 1 of 1

Wireless AP Mode: hostapd failed

Posted: Mon Feb 10, 2020 3:08 am
by scs217
I have been unable to get my STEMlab 125-14 to work in access point mode. I believe that I've followed the steps in the readthedocs networking page correctly. Connecting over ssh I see the following:

Code: Select all

root@rp-f06d16:~# systemctl restart hostapd@wlan0.service
Job for hostapd@wlan0.service failed because the control process exited with error code. See "systemctl status hostapd@wlan0.service" and "journalctl -xe" for details.
root@rp-f06d16:~# systemctl status hostapd@wlan0.service
‚óŹ hostapd@wlan0.service - Hostapd IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
   Loaded: loaded (/etc/systemd/system/hostapd@.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2020-02-10 01:55:43 UTC; 6s ago
  Process: 2554 ExecStart=/usr/sbin/hostapd /etc/hostapd/hostapd.conf -P /run/hostapd.pid -B (code=exited, status=1/FAILURE)

Feb 10 01:55:43 rp-f06d16 hostapd[2554]: nl80211: Could not configure driver mode
Feb 10 01:55:43 rp-f06d16 hostapd[2554]: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Feb 10 01:55:43 rp-f06d16 hostapd[2554]: nl80211 driver initialization failed.
Feb 10 01:55:43 rp-f06d16 hostapd[2554]: wlan0: interface state UNINITIALIZED->DISABLED
Feb 10 01:55:43 rp-f06d16 hostapd[2554]: wlan0: AP-DISABLED
Feb 10 01:55:43 rp-f06d16 hostapd[2554]: hostapd_free_hapd_data: Interface wlan0 wasn't started
Feb 10 01:55:43 rp-f06d16 systemd[1]: hostapd@wlan0.service: Control process exited, code=exited status=1
Feb 10 01:55:43 rp-f06d16 systemd[1]: Failed to start Hostapd IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator.
Feb 10 01:55:43 rp-f06d16 systemd[1]: hostapd@wlan0.service: Unit entered failed state.
Feb 10 01:55:43 rp-f06d16 systemd[1]: hostapd@wlan0.service: Failed with result 'exit-code'.
I haven't found a solution through extensive searching. Please help?