Programming issue

Applications, development tools, FPGA, C, WEB
Post Reply
Posts: 2
Joined: Thu Dec 24, 2015 2:29 pm

Programming issue

Post by Bernhard_G » Thu Sep 17, 2020 11:46 am

Hello everyboy,

my reques goes to the professionals. I am using "Red Pitaya GNU/Linux OS & Ecosystem 0.94-536".
I tried ro make the "my firrt from" from the toturial: ... stApp.html
Everthing works fine until I tried to do the compiling ( Compiling application):
make INSTALL_DIR=/opt/redpitaya
After executing this command I got the following result:
redpitaya> make INSTALL_DIR=/opt/redpitaya
make -C src
make[1]: Entering directory '/opt/redpitaya/www/apps/myFirstApp/src'
arm-linux-gnueabihf-g++ -c -Wall -fPIC -Os -s -std=c++11 -I/opt/redpitaya/include -I/opt/redpitaya/include/api2 -I/opt/redpitaya/include/apiApp -I/opt/redpitaya/rp_sdk -I/opt/redpitaya/rp_sdk/libjson main.cpp -o main.o
arm-linux-gnueabihf-g++ main.o -o ../ -shared -Wall -fPIC -Os -s -L/opt/redpitaya/lib -L/opt/redpitaya/rp_sdk -Wl,--whole-archive,--no-as-needed -lcryptopp -lrpapp -lrp -lrp_sdk -Wl,--no-whole-archive
/usr/bin/ld: cannot find -lcryptopp
/usr/bin/ld: cannot find -lrp_sdk

collect2: error: ld returned 1 exit status
Makefile:34: recipe for target 'make_c_app' failed
make[1]: *** [make_c_app] Error 1
make[1]: Leaving directory '/opt/redpitaya/www/apps/myFirstApp/src'
Makefile:24: recipe for target '' failed
make: *** [] Error 2
It seems the main problem is /usr/bin/ld: cannot find -lcryptopp & /usr/bin/ld: cannot find -lrp_sdk, which could not be found.

Does anybody has an idea how to handle this?

Best regards


Post Reply
jadalnie klasyczne ekskluzywne meble wypoczynkowe do salonu ekskluzywne meble tapicerowane ekskluzywne meble do sypialni ekskluzywne meble włoskie

Who is online

Users browsing this forum: No registered users and 6 guests