Acquisition troubles IN2

Applications, development tools, FPGA, C, WEB
Post Reply
hubev
Posts: 2
Joined: Wed Nov 25, 2020 9:33 am

Acquisition troubles IN2

Post by hubev » Wed Nov 25, 2020 9:53 am

Hi everybody,

I am trying to synchronise one pulse signal generation and acquisition with Matlab. My code is almost the same as in the exemple on RedPitaya website :https://redpitaya.readthedocs.io/en/lat ... -exm3.html.
I just set delay on 8192. And my trigger is on positive edge.
I generate a simple burst RAWU with a 1V amplitude.

It perfectly works with IN1 :)
But when I plug it on IN2, it doesn't work :(
However, I set the trigger on "CH2_PE". The delay is the same as previously.
I always obtain signal_str_2 beginning by a big number (and not by "{" as it should). The rest of datas are not the signal but 0V...

I don't understand where is the error.
In advance, thank you for your help !

hubev
Posts: 2
Joined: Wed Nov 25, 2020 9:33 am

Re: Acquisition troubles IN2

Post by hubev » Thu Nov 26, 2020 3:51 pm

Ok, I find the solution. In the code below :

Code: Select all

% Read data from buffer
signal_str=query(tcpipObj,'ACQ:SOUR1:DATA?');
signal_str_2=query(tcpipObj,'ACQ:SOUR2:DATA?');
I have to comment the first Input, so signal_str, in order to obtain signal_str_2 without problems.

But is it possible to acquire the two inputs at the same moment ?
Who has already done that ?

Post Reply
jadalnie klasyczne ekskluzywne meble wypoczynkowe do salonu ekskluzywne meble tapicerowane ekskluzywne meble do sypialni ekskluzywne meble włoskie

Who is online

Users browsing this forum: No registered users and 2 guests