LCR Meter Measurements Wrong

Applications, development tools, FPGA, C, WEB
Post Reply
EMattingly
Posts: 1
Joined: Sat Jul 10, 2021 4:26 pm

LCR Meter Measurements Wrong

Post by EMattingly » Sat Jul 10, 2021 4:53 pm

Hi,

I recently set up my Red Pitaya (125-10) with the LCR meter, and the readings are 1) extremely inconsistent (jumping around many orders of magnitude with auto-shunt, and +/- 20% or so with manually determined shunt), and 2) plainly incorrect. With a 100 Ohm resistor (measured externally as 99 Ohms) as the DUT, with 100Hz and 10 Ohm shunt it reads ~44 Ohms (~0 Deg but jumps between -5Deg, +5 Deg, so that seems correct).

Capacitor measurements were jumping between nF uF and OVER R. regardless of which settings.

I followed the hardware instructions and set the jumpers to high impedance mode, checked all SMA cables are securely attached, the BNCs are wired so the two leads associated with the red clip are plugged into LS/LD, and the other two are in HD/HS.

I'm not really sure what else to try (I've even updated the SD card with the latest stable version). Any suggestions would be greatly appreciated.

User avatar
redpitaya
Site Admin
Posts: 540
Joined: Wed Mar 26, 2014 7:04 pm

Re: LCR Meter Measurements Wrong

Post by redpitaya » Thu Aug 12, 2021 11:04 am

please let me know if the issue is manifesting after you manually update the Red Pitaya OS to the latest BETA by using this specific guide:
https://www.youtube.com/watch?v=Qq_YRv2nk3c

Post Reply
jadalnie klasyczne ekskluzywne meble wypoczynkowe do salonu ekskluzywne meble tapicerowane ekskluzywne meble do sypialni ekskluzywne meble włoskie

Who is online

Users browsing this forum: No registered users and 7 guests