Unable to make stream_app

Applications, development tools, FPGA, C, WEB
Post Reply
tinyhippo
Posts: 2
Joined: Sun Oct 10, 2021 6:37 pm

Unable to make stream_app

Post by tinyhippo » Sun Oct 10, 2021 6:57 pm

Hello,

I am sorry if my problem is obvious to solve but I am very new to red pitaya world. When I try to make a project, for example stream_app, I run the following command:

Code: Select all

make PRJ=stream_app
into Redpiyaya/fpga/folder my synthesis via vivado is working fine but then I encounter the following error:

Code: Select all

make PRJ=stream_app
hsi    -nolog -nojournal -mode batch -source red_pitaya_hsi_dts.tcl -tclargs stream_app

****** hsi v2019.1 (64-bit)
  **** SW Build 2552052 on Fri May 24 14:47:09 MDT 2019
    ** Copyright 1986-2019 Xilinx, Inc. All Rights Reserved.

source red_pitaya_hsi_dts.tcl
# cd prj/$::argv
# set path_sdk sdk
# open_hw_design $path_sdk/red_pitaya.sysdef
INFO: [Hsi 55-1698] elapsed time for repository loading 0 seconds
# set_repo_path ../../../tmp/device-tree-xlnx-xilinx-v2017.2/
ERROR: [Hsi 55-1550] Repository Directory ../../../tmp/device-tree-xlnx-xilinx-v2017.2/ doesn't exist in the disk
ERROR: [Common 17-39] 'set_repo_path' failed due to earlier errors.
INFO: [Common 17-206] Exiting hsi at Sun Oct 10 19:33:21 2021...
make: *** [Makefile:59 : prj/stream_app/sdk/dts/system.dts] Erreur 1
The problem therefore happens when running the red_pitaya_hsi_dts.tcl file. I do not really get why the path is set in a relative way here ?
Moreover, did I miss some optional installation with vivado if device-tree-xlnx-xilinx-v2017.2 is not on my computer ? (I run an extensive search on my hard drive)
Finally, should I put the files on my redpitaya on run the compilation from there ?
Thanks in advance :)

Post Reply
jadalnie klasyczne ekskluzywne meble wypoczynkowe do salonu ekskluzywne meble tapicerowane ekskluzywne meble do sypialni ekskluzywne meble włoskie

Who is online

Users browsing this forum: No registered users and 2 guests