Setting up Xilinx Vivado on Ubuntu

dedicated to the FPGA topics for all Red Pitaya programmers
Post Reply
Posts: 2
Joined: Wed Aug 14, 2019 4:31 pm

Setting up Xilinx Vivado on Ubuntu

Post by pghalverson » Thu Aug 15, 2019 6:30 pm

Hi all,

I want to make my own FPGA designs on Red Pitaya. The board works OK out of the box (the oscilloscope and signal generator web apps work).

Through the Red Pitaya site I found a nice step-by-step guide to installing Vivado on Ubuntu here:
but I have hit some snags.

So far I have done this:
--- Downloaded and installed Ubuntu 16.04.6 LTS onto a Dell computer. Works great.
--- Per the instructions, I downloaded the Vivado HLx 2017.2: WebPACK and Editions - Linux Self Extracting Web Installer
--- I got the free Xilinx License to be able to run the installer
--- I ran the installer following the excellent series of screen shots. :D
Now I ran into trouble.
After the installer successfully completed, the license manager was supposed to automatically start up, but didn't. :(
At this point I found myself going down a Linux rabbit hole of trying this and that with little success.

1) ------------------Did I make the right choice in choosing Ubuntu 16.04?
I chose 16.04 because the of the statement made here
"Red Pitaya is developed on Linux (64bit Ubuntu 16.04), so Linux is also the only platform we support."

2) ------------------Did I make the right choice in choosing Vivado 2017.2?
I chose 2017.2 because the step-by-step instructions used that version.

3) -----------------Can you suggest a combo of Ubuntu version and Vivado version that is going to work with as few glitches as possible? Preferably one that is actually working for you.

4)-----------------Alternatively, can you recommend a good set in installation instructions?

Thank you very much!!!

Peter Halverson

PS: In my "down the rabbit hole" hacking I discovered a couple interesting things.
1) I activated the root account in Ubuntu and tried reinstalling Vivado. When installation completed, the license manager magically started! Wow.
2) But, the license manager didn't accept my computer's network card's mac address which "000000000000". It turns out that the license manager assumes the network card's name is "eth0", but in Ubuntu 16.04, the card's name is changed to something else which seems to vary. :(

Posts: 2
Joined: Wed Aug 14, 2019 4:31 pm

Re: Setting up Xilinx Vivado on Ubuntu

Post by pghalverson » Mon Sep 02, 2019 5:14 pm

YES! I got Vivado 2017.2 installed and compiling. Works OK, but I am encountering some "critical errors" in the project implementation phase while compiling the 0.94 version from github. Could use some help there. I'm not holding my breath though.

I step-by-step documented the process of installing and running Vivado on my web site. Go to > Electronics > FPGA

You're welcome.

Peter H

Post Reply
jadalnie klasyczne ekskluzywne meble wypoczynkowe do salonu ekskluzywne meble tapicerowane ekskluzywne meble do sypialni ekskluzywne meble włoskie

Who is online

Users browsing this forum: No registered users and 1 guest