Fixing PTP on RedPitaya

Discussions about active development projects
Post Reply
Posts: 2
Joined: Mon Apr 02, 2018 11:13 pm
Location: Ilmenau

Fixing PTP on RedPitaya

Post by doertepeter » Tue May 15, 2018 9:26 pm

Hi all :D ,
we wanna synchronize a cluster of Red Pitayas with PTP for echo measuring.
We tried to build ptp for now some weeks - but without success yet
The main problems are these two:
1) The NIC support the hardware timestamping capabilities, but the ethernet driver, called macb, not. There is a other possible driver for same platform, the linux axi driver from Xilinx. This driver supports also hardware timestamping. I think, i will install this driver in the next week :P - and will tell you my experiences :D
*Sorry seems like I'm not allowed to post URLs - otherwise i would post site of the linux axi driver here
2) The second problem is that we can't get access to the IO Pins of the Red Pitaya (**thanks at mario for telling me). So we need to build a extra-ethernet-PHY on the Pitaya. How we fix that Problem is still unknown.

I think there are many other peoples, who want to synchronize more Red Pitayas using PTP. So please lets collect all the ideas - for fixing that. :)
Or when there is somebody who has already implement PTP on more Red Pitayas - which woould be very nice :P , then please tell us - otherwise the project is in danger of failing. :cry:

Posts: 721
Joined: Sat May 23, 2015 5:22 pm

Re: Fixing PTP on RedPitaya

Post by pavel » Tue May 15, 2018 9:53 pm

Another possibility could be to try the emacps driver: ... x_emacps.c

If it doesn't work with the recent Linux releases, then switching to an older Linux release could be a solution. I remember that the emacps driver worked with the xilinx-v2015.4 release.

You can find more details in this post.

Post Reply
jadalnie klasyczne ekskluzywne meble wypoczynkowe do salonu ekskluzywne meble tapicerowane ekskluzywne meble do sypialni ekskluzywne meble włoskie

Who is online

Users browsing this forum: Google [Bot] and 1 guest