Slow analog output DAC low voltage

Just about everything about Red Pitaya
Post Reply
davide.cryptalabs
Posts: 1
Joined: Thu Mar 31, 2022 4:06 pm

Slow analog output DAC low voltage

Post by davide.cryptalabs » Thu Mar 31, 2022 4:15 pm

I'm using the C API to set the analog output AO0 to 1.8V.
The API (rp_AOpinSetValue(0,1.8)) returns true but the output is actually 1.1V.
When I try to set a lower voltage: 0.9V on the output i get ~0.6V.
I've measured the AO0 pin with an oscilloscope.

Has anyone exeperienced this, in the documentation is clearly amrked that I can set it up to 1.8V.
Thanks

Kilroy
Posts: 29
Joined: Thu Feb 19, 2015 11:03 am
Location: Moenchengladbach, Germany
Contact:

Re: Slow analog output DAC low voltage

Post by Kilroy » Tue Aug 02, 2022 11:14 am

Yes - same here.
But I am not using the latest FPGA nor the latest API.
I have seen there are have been made some changes and I will try to figure that out.

juretrn
Posts: 33
Joined: Tue Nov 16, 2021 11:38 am

Re: Slow analog output DAC low voltage

Post by juretrn » Tue Aug 02, 2022 2:37 pm

I believe this was fixed in the latest release. We transitioned from PWM to PDM generation in the FPGA for these outputs, but we missed a parameter fix in the software.
But the latest release should now work correctly IIRC.

Kilroy
Posts: 29
Joined: Thu Feb 19, 2015 11:03 am
Location: Moenchengladbach, Germany
Contact:

Re: Slow analog output DAC low voltage

Post by Kilroy » Thu Sep 01, 2022 8:33 am

Sorry for my late reply.
I have updated all the sources (FPGA & API) and now the DAC works fine. 1.8 Volt maximum with 8 bit resolution.
Regards

Post Reply
jadalnie klasyczne ekskluzywne meble wypoczynkowe do salonu ekskluzywne meble tapicerowane ekskluzywne meble do sypialni ekskluzywne meble włoskie

Who is online

Users browsing this forum: No registered users and 2 guests