Input not reading triangle signal from radar.

Just about everything about Red Pitaya
Post Reply
ccsiim
Posts: 1
Joined: Sat Jul 15, 2017 11:55 am

Input not reading triangle signal from radar.

Post by ccsiim » Thu Jul 20, 2017 10:08 am

Hey RP!

I've just bought my own RP, so forgive me in advance, if I come of as green.
I'm using my RP as a scope and DAQ in a level measuring project, using a FMCW radar module.

Simply put, I generate a triangle signal of ~200kHz, use at as input on my radar, and read whatever comes out of my radar (I/Q-signals).

A tektronix scope will read both the generated wave and the output wave of the radar.
My RP will only read the generated wave from the signal generator.

According to the tektronix, the output frequency of the radar is also about 200kHz. The fact that my RP cant pick up the signal, but the tektronix scope can, boggles my mind. The signal seems to be the actual generated signal, just amplified down by the LNA amplifier in the radar. (Meaning the radar is not working as intended, but that is not my issue). The signal goes from ~2.3 Vpp input, to ~240mVpp output.

I'm using the power supply that comes with the purchase, I'm using direct ethernet wiring from RP to Mac. I have shortcircuited IN2 since I'm not using it.

Any idea as to why my RP can't detect the ~240 mVpp triangle output signal?

Thanks! :)

Post Reply
jadalnie klasyczne ekskluzywne meble wypoczynkowe do salonu ekskluzywne meble tapicerowane ekskluzywne meble do sypialni ekskluzywne meble włoskie

Who is online

Users browsing this forum: No registered users and 4 guests