Page 1 of 1


Posted: Wed Aug 23, 2017 7:22 am
by avlredpitaya

we got the RP for the company we are working for and we ran into some problems!

The first problem, when we want to update the RP via the "RedPitaya update manager" the update process fails everytime at point 6 (preparing to run). It simply does nothing and if we load the page again, we have a "connection refused" error. The only solution is to write a new image to the SD-Card.

We wanted to try visual programming, but when we try to start visual programming it opens a new tab ( but nothing happens... we read somewhere that we need the latest OS so we tried to update the OS and ran into the error above. After we installed a new image same problem.

And sidenote: On the page My Equipment there is a dead link (FAQ: Connectivity problems?).

Finally a question: We wanted to create a loopback between analog input and analog output (125 MSps) and we don´t want to reinvent the wheel so is there any example online and would visual programming be capable to handle it?

Hope for a solution,

-Update 230817: Visual Programming is currently not supported, so error 2 & 3 are somehow solved

Re: Problems

Posted: Thu Aug 31, 2017 10:23 am
by redpitaya

we recommend that you take our latest SD image and prepare a new SD card following the instructions.

Since release 0.97 all applications are unlocked by default. Users don’t need to register or apply unlock keys anymore.

Visual programming has now been replaced by jupyter. Examples can be found here.

You can make an internal analog loopback between analog input and analog output simply by adding the following line in any jupyter notebook:

Code: Select all

mgmt = fpga.mgmt()
# digital loopback
mgmt.loop = 0b11
kind regards Red Pitaya team