RP Board not Communicating even with IP Address

Just about everything about Red Pitaya
Post Reply
Posts: 3
Joined: Wed Mar 07, 2018 3:37 pm

RP Board not Communicating even with IP Address

Post by alex.gold » Wed Apr 18, 2018 11:25 am

Hi all,

I was using an RP board,14 bit bought about 8 weeks ago. Initially all good and working well, used a DHCP server to assign a static IP address, moved it onto the target network (no DHCP) and it was initially working fine. After a few days of intermittent use it stopped communicating. As we were mid test cycle and the board was embedded in our system, it was intermittently powered but non-functional for 2 weeks. I have done a debug and cannot understand why it won't work, or how to fix it, short of something being corrupted or gone pop on the RP board. I have a second RP that was plugged into the same system operated exactly the same way in the same environment. In system ethernet connection was through a network switch (along with the functional RP board). Inputs to the functional board were changed midway through testing to be the inputs that had originally been to the non-functional board and it worked ok, suggesting it was not out of range inputs causing issues/inputs grounding etc. HV jumpers checked to be correctly set to HV. Debugging steps post-testing have been as follows:
1. Check power, and lead connectivity (ok)
2. LEDs as described in online docs (LED on non-functional ethernet port flashing much slower than on functional RP board).
3. Heatsink temperature 56C (52C on functional board) on a 22C background.
4. Ethernet directly to PC (not through switch) still no comms.
5. Using a PC to scan IP addresses showed the non-functional device with correct MAC address at the programmed IP address - but not talking normally through a web browser at that address.
6. SSH access was not possible to this device using putty.
7. DHCP could not reprogram device address as it was set to static and without being able to talk to it, the address was not changeable.
8. Device SD card was rewritten using online process. The same steps as above repeated.
9. DHCP server could now see and assign an IP address - all other steps the same results as above.
10. On the new IP address device still would not communicate normally nor allow SSH access via putty.

Is there something I've missed or has the board gone kaputt and I need a replacement? As I had a second one in exactly the same environment talking fine via the same network infrastructure I suspect a board issue - any help would be greatly appreciated. Note: I have not used wifi or any self written apps or scripts to modify anything onboard in any way and there are no external connections from the power out pins or GPIO to drag power down etc.

The board that did work proved incredibly useful for testing (professional environment) which was very informative for our tests. If the second one could be made to work more the better.

Thank you.

Post Reply
jadalnie klasyczne ekskluzywne meble wypoczynkowe do salonu ekskluzywne meble tapicerowane ekskluzywne meble do sypialni ekskluzywne meble włoskie

Who is online

Users browsing this forum: No registered users and 21 guests