Page 1 of 1

Acq Problem: Phasejumps

Posted: Wed Aug 21, 2019 3:16 pm
by CBrehm
Hi everybody.

I am experiencing a strange problem in acquisition of data: I read out 1buffer of Fast AI1+2 and I see phasejumps of the signal at varying positions. I am not too much concerned, if the phase jumps would arrise at the same time/sampleposition but they are obviously random.

This problem does not occur at every acq, but one time every 1-15 trys.
Does somebody have an idea how to avoid this?
I already tried different settings for sample delay, trigger channel1/2; positive edge and so on. But I would like to understand this problem.

I did try Labview and C-code on the redpitaya, but no fortune so far.

In the image you see a phase jump right at the beginning occuring in both signals, and a second time only for the red line.

thanks for your help!
best regards

edit: frequency is 12kHz; dez64; using stempab 125-14

Re: Acq Problem: Phasejumps

Posted: Thu Aug 22, 2019 12:43 pm
by CBrehm
Thinking about it, the phase jumps are due to a loss of data, since there are no wicked jumps or else.

I also tried the Oszi code designed by marceluda:
were I see the same pictures:

I see a phase jump in both signals, propably when a new buffer is read.
What I worry is, when I only see a jump in one signal....