Page 1 of 1

Urgent: CPU LED not blinking

Posted: Wed Jul 07, 2021 1:55 pm
by corinnahaegele
Hey there,

I'm fairly new to working with the Red Pitaya(Model 125-10) and to be honest it's giving me a quite hard time. I followed the instructions and downloaded the latest stable ecosystem ( ... Dcard.html) , flashed it on the SD-Card and everything worked just fine up until yesterday.
Today I turned on the power and noticed that the LEDs are not blinking as they are supposed to. Green is always on, orange at like 50% intensity (not blinking), red in not blinking at all.
If I unplug the power cable and wait for 2 minutes, blue LED will turn ON (so green &blue are ON, orange at 50%), but red LED is still OFF.

So far, I've tried flashing a new image on the SD card and when that didn't work I tried it with every other SD card. None of the other posts in this forum regarding this topic were solved, so please help me to find a solution!

Thank you!!

Re: Urgent: CPU LED not blinking

Posted: Wed Jul 07, 2021 2:26 pm
by pavel
I'd suggest checking the boot process using USB/serial console: ... nsole.html

Maybe you'll see some error messages that would help better understand the problem.

If the console shows nothing and the replacement of the SD card doesn't help, then I'd suggest contacting the Red Pitaya support. The e-mail address can be found at the following link:

Re: Urgent: CPU LED not blinking

Posted: Thu Aug 12, 2021 9:20 am
by redpitaya
please let me know if the issue is manifesting after you manually update the Red Pitaya OS to the latest BETA by using this specific guide: