Page 1 of 1

Ethernet problem/ WIFI Dongle

Posted: Wed Aug 04, 2021 2:27 pm
by corinnahaegele
Hey there,

I recently bought a breandnew Red Pitaya (125-10) and did the setup as described in the documentation. I connected the board directly to my Laptop via ethernet-cable and had access to the web applications (worked only in Windows browsers). However, when I try to use the web interface in my Oracle Virtual Machine (Ubuntu 20.04 LTS GUI, Guest Additions are installed and adapter manager is on "NAT"), no connection can be established.
Part of my Project is to use the Red Pitaya as server. Therefore I have to establish a SSH connection via Ubuntu terminal, but since the virtual machine won't find the board, that effort seems hopeless. :| Wierdly, the last board(also 125-10, same OS-Version), which I gave away, worked just fine.

Since I couldn't connect via ethernet connection I bought a wifi dongle (TL-WN725N TP-Link with 802.11n protocoll), but the network manager (web applications) still shows: "no wifi-dongle connected.". Also I noticed, that the dongle's LED isn't even turned on while plugged into the RP's USB port.

So I guess, I have several questions:
1. Does anyone know a way to fix the ethernet-problem with Orcale VirtualMachine?
2. Why does my Red Pitaya not even see the WIFI-Dongle? Did I buy the wrong one? If so, where can I buy the right one?
3. Is my Red Pitaya board simply "broken"? Should I return it?

And yes, I tried shutting the devices down and flashed SD-cards several times.

Thanks a lot! :)

Re: Ethernet problem/ WIFI Dongle

Posted: Wed Aug 04, 2021 9:29 pm
by pavel
I think that your Red Pitaya board is OK.

If you are using one of the SD card images provided by Red Pitaya developers, then it is normal that its default configuration does not work with your setup. The direct Ethernet cable connection is by default configured to use a link-local IP address that does not work with NAT.

I think the first problem can be solved by following the static IP configuration instructions at the following link: ... connection

The SD card images provided by Red Pitaya developers have only a few Wi-Fi drivers enabled. That is probably why your Wi-Fi adapter based on the RTL8188EUS chipset does not work with these SD card images.

In my SD card images, more Wi-Fi drivers are enabled. For example, I have a Wi-Fi adapter based on the RTL8188EUS chipset and it works with my SD card images. These SD card images can be found at the following links: ... d-blinker/