STEMLab 125-14 Connection & Update Issues

Just about everything about Red Pitaya
Post Reply
m4rshk0pf
Posts: 1
Joined: Tue Oct 26, 2021 10:16 am

STEMLab 125-14 Connection & Update Issues

Post by m4rshk0pf » Thu Oct 28, 2021 8:59 am

Hi,

we are using a STEMLab 125-14 RedPitaya and had some trouble with it recently.
We had connection issues, when using it with the 802.11n Wifi dongle in AccessPoint Mode.
Further the RedPitaya shows an Error when it should go online for some functions in the Web Application (OS Update, App Shop).


Initially we tried to connect to it via the Wifi from its own 802.11n Dongle, using it as an Access Point. This connection intially worked, but the web interface had a hard time loading applications and the connection would time out after a few minutes in any application, or even more often while trying to load the main menu or an application. We tried switching browsers between Chrome, Firefox and Edge at this time, but all had roughly the same problems.
Are those connection losses and long loading times usual, when using the Wifi dongle of the RedPitaya as an Access Point?

In order to circumnavigate those loading times, we connected the RedPitaya directly to a PC via Ethernet.

In both cases when we tried to update the firmware directly from the web application, via the settings menu, we recieved an error message, that the RedPitaya was not connected to the internet.

We tried to resolve the issue and get the RedPitaya online by connecting it to a router with DHCP (both connection via ethernet and connection via Wifi, with the RedPitaya in Client Mode).
Those connections had faster loading times and a better stability than the ones described earlier.

But the issue with the RedPitaya not being able to update its OS via the Web Application persisted.
So we moved to updating the OS directly on the SD Card as described in the documentation in 1.3. With the newest stable version 1.04 we ran into error messages from Win32DiskImager, stating that it couldn't write on this partition. After formatting and repartitioning the SD Card an failing with 1.04 multiple times we tried using the versions 0.98, because that is also the most recent ecosystem to be found here: https://downloads.redpitaya.com/downloa ... ab-125-1x/ , and 1.03.
With both versions we got the RedPitaya to run again, but the issue that it wouldn't go online to update its OS remained.
After further searching we found that a problem with writing the image of version 1.04 via Win32DiskImager existed and was reported, so we switched to BalenaEtcher and finally managed to get the RedPitaya with 1.04 running.

The issue with the RedPitaya, showing an error message, everytime it would have to go online, to update, or to use the application store is still not resolved.
We even tried pinging google . com through the SSH, as suggested in the Documentation under 1.6.7, and were able to reach it with a Packet loss of 4% in over 110 Packets sent.
Is this a common or reported issue?

After updating the OS directly on the SD we had to directly connect to a router or PC, to redefine the Wifi Network and put in Access Point Mode.
Is there another way to do this, or is a physical connection required?

I would be glad if anyone could help, in any case I hope that this Thread will be seen as a report of the described problems.
If anyone has an idea, feel free to share, we would be happy to give you further information.

Thanks for your help.

User avatar
redpitaya
Site Admin
Posts: 568
Joined: Wed Mar 26, 2014 7:04 pm

Re: STEMLab 125-14 Connection & Update Issues

Post by redpitaya » Fri Nov 05, 2021 10:26 am

Dear all,
is your Red Pitaya unit refusing to update?

This can happen either because the version you are trying to update from is too old, or the version of the Red Pitaya OS is incompatible with the base Linux that is running on your board.

Here's how to solve this. You can manually update both at the same time and avoid lengthy procedures. Another advantage of doing this is the simplicity of the process.


Of course, as always, the first step would be to make a backup if you have some saved work on the unit, or simply use a different micro SD card. Please make sure to update the web user interface after installation, since some things can be cached from the previous version and this can lead to unpredicted behaviour.

We recommend you to always update manually to our latest Beta OS, it works smoothly and it has all the latest features implemented and the reported bugs fixed.

You can use this video guide we made below.
https://www.youtube.com/watch?v=Qq_YRv2nk3c



You can download the image files for free and also check the changelogs to see what improvements we constantly make on a monthly basis.



And no, it does not matter how old your board is. Even though the OS updates are different for different models, they are all updateable.

UPDATE THE OS
All the best,
Red Pitaya engineering team

User avatar
redpitaya
Site Admin
Posts: 568
Joined: Wed Mar 26, 2014 7:04 pm

Re: STEMLab 125-14 Connection & Update Issues

Post by redpitaya » Fri Nov 05, 2021 10:30 am

Regarding the Wifi usb dongles, please note that the one included with our bundles have been tested and work fine.
Also we received reports that there is a new EDIMAX unit now EW-7811Un that has also a V2 in the name. This new dongle does seem to use a different driver and it is not compatible with the Red pitaya OS at the moment. We are working on it.

Post Reply
jadalnie klasyczne ekskluzywne meble wypoczynkowe do salonu ekskluzywne meble tapicerowane ekskluzywne meble do sypialni ekskluzywne meble włoskie

Who is online

Users browsing this forum: No registered users and 8 guests