Running into 'bad value' error when installing Makefile.x86

Just about everything about Red Pitaya
Post Reply
sslerose
Posts: 34
Joined: Sat Nov 26, 2022 12:43 am

Running into 'bad value' error when installing Makefile.x86

Post by sslerose » Sun Jan 29, 2023 3:42 am

I have been trying to build an FPGA image on my STEMLab 125-10 (following the docs from Red Pitaya here) for around 6 months now and at my current state I cannot get past the Makefile.x86 install command.

I have the entire ecosystem installed from 3.2.2.4.2, however, after calling the settings.sh and disabling the library overrides, I run

Code: Select all

make -f Makefile.x86 install MODEL=Z10
which throws a bad value error for the '-march=' switch, with a small snippet of the error shown below:

Code: Select all

make[1]: Entering directory '/home/sslerose/RedPitaya/tmp/u-boot-xlnx-redpitaya-v2016.4.1'
#
# configuration written to .config
#
make[1]: Leaving directory '/home/sslerose/RedPitaya/tmp/u-boot-xlnx-redpitaya-v2016.4.1'
make -C tmp/u-boot-xlnx-redpitaya-v2016.4.1 arch=ARM CFLAGS="-O2 -mtune=cortex-a9 -mfpu=neon -mfloat-abi=hard"
make[1]: Entering directory '/home/sslerose/RedPitaya/tmp/u-boot-xlnx-redpitaya-v2016.4.1'
scripts/kconfig/conf  --silentoldconfig Kconfig
  CHK     include/config.h
  GEN     include/autoconf.mk
  GEN     include/autoconf.mk.dep
  GEN     spl/include/autoconf.mk
  CHK     include/config/uboot.release
  CHK     include/generated/version_autogenerated.h
  CHK     include/generated/timestamp_autogenerated.h
  UPD     include/generated/timestamp_autogenerated.h
  CC      lib/asm-offsets.s
cc1: error: bad value (‘armv5’) for ‘-march=’ switch
cc1: note: valid arguments to ‘-march=’ switch are: nocona core2 nehalem corei7 westmere sandybridge corei7-avx ivybridge core-avx-i haswell core-avx2 broadwell skylake skylake-avx512 cannonlake icelake-client rocketlake icelake-server cascadelake tigerlake cooperlake sapphirerapids alderlake bonnell atom silvermont slm goldmont goldmont-plus tremont knl knm x86-64 x86-64-v2 x86-64-v3 x86-64-v4 eden-x2 nano nano-1000 nano-2000 nano-3000 nano-x2 eden-x4 nano-x4 k8 k8-sse3 opteron opteron-sse3 athlon64 athlon64-sse3 athlon-fx amdfam10 barcelona bdver1 bdver2 bdver3 bdver4 znver1 znver2 znver3 btver1 btver2 native
make[2]: *** [Kbuild:44: lib/asm-offsets.s] Error 1
make[1]: *** [Makefile:1263: prepare0] Error 2
make[1]: Leaving directory '/home/sslerose/RedPitaya/tmp/u-boot-xlnx-redpitaya-v2016.4.1'
make: *** [Makefile.x86:373: tmp/u-boot.elf] Error 2
I have tried looking for the source of the error within the code so that I may change it, but I can't seem to find it, and the solutions I have found (namely this solution from Nils Roos) have not worked for me. Any help would be greatly appreciated!

For reference, I am running WSL with Ubuntu 22.04.1 LTS on a Windows 10 desktop.

Note: I copied the discussion to "Software" but don't know how to remove this post, apologies.

juretrn
Posts: 107
Joined: Tue Nov 16, 2021 11:38 am

Re: Running into 'bad value' error when installing Makefile.x86

Post by juretrn » Sun Jan 29, 2023 8:02 pm

This is a typical problem when first trying to set up a new build environment and compiling uboot for a Zynq.
See this :
https://support.xilinx.com/s/question/0 ... uage=en_US

I believe the magic line is this:
export CROSS_COMPILE=arm-linux-gnueabi-

or you can try the one in settings.sh

export CROSS_COMPILE=arm-linux-gnueabihf-

Post Reply
jadalnie klasyczne ekskluzywne meble wypoczynkowe do salonu ekskluzywne meble tapicerowane ekskluzywne meble do sypialni ekskluzywne meble włoskie

Who is online

Users browsing this forum: No registered users and 15 guests