Page 1 of 1

Can't install app from bazaar

Posted: Wed Oct 22, 2014 6:09 am
by sa-penguin
Just got my RP today, so excuse me if I'm doing something silly, but...
I just tried (and failed) to install the LCR app.

I clicked on the "Install" button, the screen went blank... came back eventually, but LCR was still listed as "Install".
Tried to go back to menu of RP, got "404 Not Found" error. (nginx/1.5.3)

The thing is: to get the RP to connect AT ALL, required some jiggery-pokery. I'm using an Apple Mac, and it's quite a distance from my router.
I had to set the Mac to "forward" my Internet connection, then plug the RP into the Ethernet port, for the MAC address to work with your home page.
Could this setup be interfering with the Bazaar's "install" procedure?

Is there another way of downloading / installing apps? I'd be happy to keep a file on my system, and either do a local transfer, or a CLI-based install.

Re: Can't install app from bazaar

Posted: Wed Oct 22, 2014 11:02 am
by Nils Roos
To install applications "by hand", follow these instructions, under point latest development versions.

Re: Can't install app from bazaar

Posted: Wed Oct 22, 2014 2:07 pm
by sa-penguin
Thanks for that pointer.
It's not totally accurate, but it got me there. The package I was trying to install is the LCR test, and this isn't at
Being a contributed app, I found it at:

It's getting late here in Adelaide, so I'll be editing SD cards etc. tomorrow.
Thanks again for the tip.

Re: Can't install app from bazaar

Posted: Wed Oct 22, 2014 7:50 pm
by Nils Roos
Good find, I didn't know that the contributed apps are there.

Re: Can't install app from bazaar

Posted: Thu Oct 23, 2014 2:36 am
by sa-penguin
Aaah - success.

As I'm using a Mac, and the Safari browser recently got updated (with OSX Yosemite) I thought that might be part of the problem. So I installed Firefox and tried that.
Slightly better results: hitting the "Install" button on the Bazaar web page produced a swirly icon, similar to the one one Youtube when it's downloading. However, the RP still seemed to lock up at the end.

So, as suggested, I grabbed the sourece ZIP file. I then put the Micro SD in my Mac, and copied the innards to the "www/apps/" directory.
Rebooted the RP - and the LCR option is now available.

In conclusion: I don't know why the Bazaar "install" doesn't work for me, but I've learned enough to get around it.
I hope there's enough detail here, to help out anyone who has similar issues.