No network when using UART

Placement, modules, components and accessories; the ones that exist and the the nice-to-be's
Post Reply
Posts: 1
Joined: Wed Oct 04, 2017 9:45 am

No network when using UART

Post by bma_fog » Wed Oct 04, 2017 10:46 am

Hello world,

Since one mounth ago, i am using a display controlled through UART pins. The peripheral is OK and my C program is running perfectly.

But i noticed, when i power ON my system (RedPitaya + display), Redpitaya cannot connect to network. I tried to restart network service via systemctl, to reload DHCP service, to configure networks configs files, to use an external power, to change ecosystem version (0.94 and 0.97) and to change peripheral (i used another UART peripheral). But nothing solved my problem.

I specify that my problem appears only when i power ON (not reboot or shutdown) my Redpitaya and display together. Actually, i must wait 1-2 seconds after RedPitaya power supply before connect my display for connect to network.

Is it normal ?

Thanks for answers.

Post Reply
jadalnie klasyczne ekskluzywne meble wypoczynkowe do salonu ekskluzywne meble tapicerowane ekskluzywne meble do sypialni ekskluzywne meble włoskie

Who is online

Users browsing this forum: No registered users and 2 guests