Page 1 of 1

No network when using UART

Posted: Wed Oct 04, 2017 10:46 am
by bma_fog
Hello world,

Since one mounth ago, i am using a display controlled through UART pins. The peripheral is OK and my C program is running perfectly.

But i noticed, when i power ON my system (RedPitaya + display), Redpitaya cannot connect to network. I tried to restart network service via systemctl, to reload DHCP service, to configure networks configs files, to use an external power, to change ecosystem version (0.94 and 0.97) and to change peripheral (i used another UART peripheral). But nothing solved my problem.

I specify that my problem appears only when i power ON (not reboot or shutdown) my Redpitaya and display together. Actually, i must wait 1-2 seconds after RedPitaya power supply before connect my display for connect to network.

Is it normal ?

Thanks for answers.

Re: No network when using UART

Posted: Wed Mar 04, 2020 11:05 am
by mbories
I guess it is too late now, but in case anyone is interested, this seems to be a feature and not a bug :mrgreen: Here is the comment from our engineer:
"The Zynq device after power-on samples seven „Boot Mode strap pins” and stores the sampled value in a read-only register (therefore we cannot modify it from software side later).
The problem caused by the UART1 TXD (PS_MIO8_500) pin, which act as a voltage mode (VMODE[1]) after power-on (see page 166, Table 6-4:Boot Mode MIO Strapping Pins in the Zynq TRM).
If something pulls up this pin at power-up - it force the device to use 1.8V IO level for BANK1. Unfortunately the Ethernet interface (and some other peripheral) connected to BANK1 and works incorrectly on 1.8V."
The only solution is to relocate the UART1 pins (for instance replace the SPI pins).
Best regards,