Page 2 of 2

Re: RP 0.98-647 / Wifi dongle not recognized anymore

Posted: Mon Oct 23, 2017 12:00 pm
by redpitaya
Hi,

it seems that booth WiFi dongles were recognized by your Red Pitaya.

We've also tested again both WiFi dongles and it looks like we can not reproduce your problem.

Here are some recommendations that may help you:
  1. download red_pitaya_OS-stable.img.zip image from our download server
  2. flash your SD card with this image, then put it in your RP without any modifications
  3. test again
  4. try force refreshing your browser, sometimes things get stuck in browser cash
  5. check that you are using the correct power supply: 5 V / 2 A micro USB power supply
kind regards Red Pitaya team

Re: RP 0.98-647 / Wifi dongle not recognized anymore

Posted: Mon Oct 23, 2017 10:59 pm
by hvanmunster@gmail.com
Hi,
no, I am connected directly to my home wifi router without a repeater.
I reviewed the instructions for wireless setup as described in the STEMlab documentation rel 0.97 (pdf-version)
I am now using 0.98, but I suppose the instructions are identical.

When I try to create the wpa_supplicant.conf file using the wpa_passphrase command:
# wpa_passphrase <ssid> [**my_wifi_key_**] > /opt/redpitaya/wpa_supplicant.conf
(MIND the # sign. I can't get the dollar sign ($) => what difference does this make?)

then I get: "-bash: ssid: No such file or directory"
I tried this from different locations (from "root"; from "/etc/wpa_supplicant" and from "/opt/redpitaya" working directories)

I manually created an empty wpa_supplicant.conf file using nano: same result (No such file or directory).

Even the instrucion "# wpa_passphrase <ssid> [**my_wifi_key_**] " without the 'forward' sign > already generates the error 'no such file or directory'

Any suggestions?
Thanks!

Re: RP 0.98-647 / Wifi dongle not recognized anymore

Posted: Tue Oct 24, 2017 8:22 pm
by hvanmunster@gmail.com
Hi,

no i am not working via a repeater. The RP-wifi is in the direct neighborhood of my main router ==> should be able to make a direct connection.

In the mean time i did some further tests and followed the steps as described in the Redpitay STEMlab documentation 0.97 (i guess this must be identcial to 0.98?)
It appears that the wpa_passphrase tool is unable to create the wpa_supplicant.conf file.
When I launch the code below, I always get an 'No such file or directory' error

# wpa_passphrase <ssid> [**keycode_of_my_router**] > /opt/redpitaya/wpa_supplicant.conf

Note that in the documentations the code starts with a dollar ($) sign in stead of the hash #, but I don't seem to get this $ sign in my terminal (I used putty ssh connection to login)
I tried this command from the root working directory as well as from the /opt/redpitaya working directory: no luck.
I manually created an empty wpa_supplicant.conf file using nano, hoping that the wpa_passphrase tool would overwrite the file with the correct configuration syntax, but I still got the 'No such file or directory' error.

Any suggestions?
Best regards,
Herman

Re: RP 0.98-647 / Wifi dongle not recognized anymore

Posted: Tue Oct 24, 2017 9:08 pm
by hvanmunster@gmail.com
Hello again.

Problem solved!
Thanks for your help. I re-installed everything as you suggested. Now the dongle is recongized.
It is a bit strange. The very first person who responded to my question also suggested to install the stable image. The problem had started in the first place by installing that stable image (which was btw the same image as the one I installed only minutes ago)
Something must have gone wrong during that installation.

Please ignore my previous (redundant) post.
Thanks again everyone for the support!
Best regards,
Herman.

Re: RP 0.98-647 / Wifi dongle not recognized anymore

Posted: Thu Oct 26, 2017 9:20 am
by amike88
Hey,

I am just glad that it worked out :)

Re: RP 0.98-647 / Wifi dongle not recognized anymore

Posted: Tue May 22, 2018 7:03 pm
by ducatistou
Hello,
I have exactly the same problem since I upgraded to 0.98 (stable and Beta) but it is not solved after reinstalling as suggested.
Still cannot connect to wifi as client nor access point
Direct LAN connection to PC does not work either.
The only way to connect to RP since 0.98 is via router with LAN ...
Thanks if anyone can help

Eric

Re: RP 0.98-647 / Wifi dongle not recognized anymore

Posted: Wed Jun 27, 2018 9:58 am
by Peterh61
Hello,
same problem after update to 0.98.617 marked as "stable version"?
Update to 0.98.685 (beta) lead to a recognised WLAN dongle, but neither settings for "client" (none of my APs are listed), nor the"access point creation" mode will work anymore...

Any idea from professional side?

Thank you very much in Advance.

Peter

Re: RP 0.98-647 / Wifi dongle not recognized anymore

Posted: Tue Dec 04, 2018 10:50 pm
by ElectroNick
For me it worked if the wifi dongle is plugged after power-on