Page 3 of 3

Re: RP 0.98-647 / Wifi dongle not recognized anymore

Posted: Fri Sep 20, 2019 8:23 pm
by jmadsenee
Just to confirm from my earlier post, the PAU05 dongle still seems to be working without a problem; I've powered up/down probably a dozen times. Just to be clear, I'll explain how I get the wireless AP set up. As I said above, I do not use the web setup/network manager.
  • I image the uSD card with the latest stable build (in this case Version 0.98, Build 694).
  • I copy my hostpad.conf file (see below) to the root directory of the 124MB partition.
  • I insert the card into the RP and power up.
  • I open a terminal window and copy my interfaces file (see below) into the /etc/network directory:

    Code: Select all

    scp /home/john/Projects/DAQ_RedP/interfaces root@rp:/etc/network/interfaces
I'm not sure that the interfaces file needs to be copied; it seems to work without it, but everything I found on the web talked about having it....

John

My hostapd.conf file:

Code: Select all

interface=wlan0
ssid=potato
driver=nl80211
hw_mode=g
channel=6
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=2
wpa_passphrase=password
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
My interfaces file:

Code: Select all

auto wlan0
iface wlan0 inet static
	address 192.168.128.1/24
	netmask 255.255.255.0

Re: RP 0.98-647 / Wifi dongle not recognized anymore

Posted: Fri Sep 27, 2019 5:00 pm
by November_SSN
So, is that recurring issue solved, or is there a quick way to fix it? Because one of the reasons I'm looking at Red Pitaya would be to work with a couple meteorological instruments at one of these houses for sale in Alicante, since I plan to use it to keep the pool and plants in shape even when I'm away thanks to a home automation system.

Re: RP 0.98-647 / Wifi dongle not recognized anymore

Posted: Sun Oct 13, 2019 2:35 pm
by Peterh61
Hello John,

thank you very much for the hints.

I'll try to get the PAU05, but
Amazon -> dont't ship to Austria
eBay -> sold out.

However, I will get it or compatible, even if I had to travel to Panda in San Jose, fixing this s... problem finally ;-)

BR Peter

Re: RP 0.98-647 / Wifi dongle not recognized anymore

Posted: Mon Oct 28, 2019 11:37 am
by Peterh61
Hello,

I have to report success :D

I bought the PAU06 from US Amazon and followed the instructions of John.

Now it works as aspected. According to the data-sheet of the PAU06 it has the same RT5372 chipset inside, this was the precondition I think.

Once again, many thanks to John!

Greetings from Austria
Peter