Page 1 of 1

Cant access my RP

Posted: Mon Jan 06, 2020 8:47 pm
by PsihoPanda
I suddenly cant connect to my RP anymore.
I plug it in and all the leds work as they should green and blue on red bliknih faster and orange slower. But when i type the IP in search bar and hit enter i get "Getting list of application" and red and orange LED stop working.
I tried rewriting SD card with multiple versions of OS but problem persists.
I hope i didn't damage the hardware in some way, and if i did is there any way to fix it?

Re: Cant access my RP

Posted: Mon Jan 06, 2020 8:54 pm
by PsihoPanda
I rewrited SD card with 30.jan.2019 version and now the red and orange leds are on constantly

Re: Cant access my RP

Posted: Sun Mar 29, 2020 8:15 pm
by dl2ja
Hello PsihoPanda,

Same happened to me recently. I still can access the RP via the USB-COM with putty or ssh and all the boot messages look good but as soon as I connect via ethernet the RP hangs up.
Could you find a solution for this?

Regards Werner,

Re: Cant access my RP

Posted: Mon Apr 06, 2020 8:56 am
by redpitaya
I recommend contacting

Re: Cant access my RP

Posted: Sun Apr 12, 2020 3:16 pm
by scietech
Good morning, sir,

Here are several ways to solve or understand your problem:

- Try another SD card

- Try to connect in SSH on your board without using the WEB interface. Then run the FPGA program:

Code: Select all

cat /opt/redpitaya/fpga/fpga_0.94.bit > /dev/xdevcfg 
If after this step, the two LEDs remain fixed, it's because you have a problem loading the FPGA, or it's a reading problem on the SD card (change SD card), or it's a writing problem (and I don't know what to do). If all goes well, that's not the problem.

- Try to use your card in SSH ( turn on a LED ).

Give us a feedback on these Tests

Re: Cant access my RP

Posted: Tue Apr 28, 2020 10:22 pm
by dl2ja
Hi Scietech,
Thanks for your mail. Unfortunately I noticed it too late. SD card, network and cable swaps to no avail. The board is already send to RP company with unpleasant results:

Board cannot be tested due to modification of "External ADC Clock" which I made according to companies suggestion.

Your proposal to reload the FPGA to them was also refused - see above.

So I send money for a new board, asked to send me the old one back for further own failure tracing but they refused because the broken board will be refurbished. How this is done without failure identification seems to be a secret.

Here I stand, head in hand, turn my face to the wall (old Beatle song ;) ) I let you know about further hopefully enjoyable results of this thread.

Re: Cant access my RP

Posted: Wed May 06, 2020 7:27 pm
by dl2ja
Hello Scietech,

I got my broken RP back and tried your proposal. RP returned with no message only the prompt and failure still exists.
SD card works on 2nd RP, software latest release from RP, same also with Pavel Demin's release. So looks definitly as a FPGA problem.