Input stage overshoot

Placement, modules, components and accessories; the ones that exist and the the nice-to-be's
Post Reply
cgo75
Posts: 1
Joined: Mon Sep 21, 2015 3:18 pm

Input stage overshoot

Post by cgo75 » Wed Apr 08, 2020 3:26 pm

Hi,
When I connect the analog output of Red Pitaya STEMLAB 125-14 to the analog input of the same device (loopback), using a BNC cable (no probe), I get the following ( HV, 2KHz, 2 Volts peak to peak) :see 2nd picture

In // I connect the output of Red Pitaya (STEM 125-14) to my oscilloscope (Hantek 4102C) with the following result : see 1st picture

It seems obvious the the input stage of Red Pitaya is overshooting. I went through the forum and found a previous thread named "Input Stage Inerfections" but I didn't see a clear and usable fix for this problem.

I do not use any probe, only straight 50 ohms cables with BNC connections. I try to load the output with a 50 ohms load without any change (obvious).

The unit is a new one delivered in 2019. It replaces a previous unit that didn't show the same issue (as far as I remenber).

Please help

cgo75
You do not have the required permissions to view the files attached to this post.

User avatar
redpitaya
Site Admin
Posts: 368
Joined: Wed Mar 26, 2014 7:04 pm

Re: Input stage overshoot

Post by redpitaya » Tue May 05, 2020 7:19 am

And what happens if instead of the regular cables that you used on Red Pitaya, you are making the connection with the hantek probe cable?

Post Reply
jadalnie klasyczne ekskluzywne meble wypoczynkowe do salonu ekskluzywne meble tapicerowane ekskluzywne meble do sypialni ekskluzywne meble włoskie

Who is online

Users browsing this forum: No registered users and 3 guests