Red Pitaya PuTTY connection

Just about everything about Red Pitaya
Post Reply
blacksea680
Posts: 8
Joined: Wed May 31, 2023 6:07 pm

Red Pitaya PuTTY connection

Post by blacksea680 » Mon Sep 18, 2023 6:50 am

I'm trying to connect to my RP (STEMlab 125-14) through a PuTTY connection, but it says connection rejected every time. I realized that typing the RP IP address into the browser did not work, and that the orange LED was not on at all, so I tried installing the newest versions of SD images for Windows following instructions.
The first one I tried was Latest Stable 125-14/10, which did not change anything. The second one was Latest Beta 4-Input which now I have only green and orange non-blinking LEDs. I'm not sure what I'm doing wrong, is the problem not about the SD at all? Is there another way to make a connection through PuTTY?

User avatar
redpitaya
Site Admin
Posts: 861
Joined: Wed Mar 26, 2014 7:04 pm

Re: Red Pitaya PuTTY connection

Post by redpitaya » Fri Sep 22, 2023 12:13 pm

Hello blacksea680!

Thank you for writing on the forum and sorry for the late reply.

Please make sure that you have the correct version of the OS installed on your board.
For STEMlab 125-14 you have the following options:
- 1.04 OS - OS versions labeled with STEMlab 125-14 & STEMlab 125-10 https://redpitaya.readthedocs.io/en/lat ... ns-1-04-os
- 2.00 (Unified OS) - will work on all boards regardless of the model

Please note that 1.04 OS versions for other board variations other than STEMlab 125-14 will NOT work with your board ("STEMlab 125-14 4-Input" is different from "STEMlab 125-14").

If you are unable to connect to the board using a browser (we recommend Google Chrome), the Putty connection will also fail. Please check the FAQ section for tips regarding this:
https://redpitaya.readthedocs.io/en/lat ... g.html#faq

Should you have any other questions, please let me know.

Here is a reference LED boot sequence: https://www.youtube.com/watch?v=9xZCAkXAkw8

blacksea680
Posts: 8
Joined: Wed May 31, 2023 6:07 pm

Re: Red Pitaya PuTTY connection

Post by blacksea680 » Tue Feb 06, 2024 10:37 pm

Thank you for the advice; I installed the Latest Stable (2.00-23) for all OS, and the LED blinkers are working as they should (blinking red, stable green and blue). I'm also able to connect to RP main page through Chrome. However, I still can't establish an ssh connection with PuTTY (gives the error "Network Error: Connection refused"). Do you have any ideas on what the reason might be?

User avatar
redpitaya
Site Admin
Posts: 861
Joined: Wed Mar 26, 2014 7:04 pm

Re: Red Pitaya PuTTY connection

Post by redpitaya » Wed Feb 07, 2024 11:31 am

Try to use the standard terminal or Command prompt in Windows and type in:
"ssh root@rp-xxxxxx.local", you can also use "ssh root@<Red Pitaya IP address>".

Alternatively, reflash the 2.00-23 image to the SD card a second time. This fixed the problem for me when I experienced it.

blacksea680
Posts: 8
Joined: Wed May 31, 2023 6:07 pm

Re: Red Pitaya PuTTY connection

Post by blacksea680 » Wed Feb 14, 2024 6:01 pm

Thank you so much, I managed to connect to it on the Terminal!

Post Reply
jadalnie klasyczne ekskluzywne meble wypoczynkowe do salonu ekskluzywne meble tapicerowane ekskluzywne meble do sypialni ekskluzywne meble włoskie

Who is online

Users browsing this forum: No registered users and 2 guests