Application Error - Application not loaded

Just about everything about Red Pitaya
Post Reply
andyjprice
Posts: 3
Joined: Wed Oct 01, 2014 9:16 pm

Application Error - Application not loaded

Post by andyjprice » Wed Oct 01, 2014 9:21 pm

I've just received my Red Pitaya and cannot get any of the applications to run.

I get the following message window ... "Application Error - Application not loaded" with an option to retry or restart. If I retry or restart I keep getting the same message.
Console says: Unhandled fault: external abort on non-linefetch (0x1018) at 0xb6093000
I have tried direct cable connection and wireless.
I have tried various SD cards. Uninstalled and reinstalled the applications. No joy.
Can anybody help please?
Many thanks.

ulfh
Posts: 5
Joined: Tue Jun 10, 2014 2:16 pm

Re: Application Error - Application not loaded

Post by ulfh » Thu Oct 02, 2014 10:22 am

I am NOT an expert on Red Piatya, but I have observed the following on my system:

If I connect to redpitaya.com and then to my device, I will be able to run the applications without any problem. If I try to connect directly to the address of my device from my web browsers, I most of the time get a similar error.

Hope it's not supposed to be like this, because then I cannot use the device if I'm not on the Internet.

Regards

Ulf :(

andyjprice
Posts: 3
Joined: Wed Oct 01, 2014 9:16 pm

Re: Application Error - Application not loaded

Post by andyjprice » Thu Oct 02, 2014 11:31 am

Thanks for your advice Ulf,

Unfortunately I'm still getting the same message .... on all applications.

Regards,
Andy

andyjprice
Posts: 3
Joined: Wed Oct 01, 2014 9:16 pm

Re: Application Error - Application not loaded

Post by andyjprice » Fri Oct 03, 2014 5:01 pm

Just got back onto this ....

If I try and run any of the console applications I get a similar fault message - for instance:

redpitaya> acquire 100
Unhandled fault: external abort on non-linefetch (0x1018) at 0xb6cc3000
Bus error

I'm running out of ideas now - does this sound like a hardware fault? :(

Thanks,
Andy

JPCoetzee1
Posts: 8
Joined: Sun Sep 24, 2017 9:53 am

Re: Application Error - Application not loaded

Post by JPCoetzee1 » Fri Dec 07, 2018 8:28 pm

Four years too late to help, but...

I'm getting going with Red Pitaya and found the same problem. For me it is fixed by loading a specific FPGA image. From halfway down the page at https://redpitaya.readthedocs.io/en/lat ... e/clt.html :

"Note - For correct operation of the acquire tool, it is mandatory that the correct FPGA image is loaded. Please note, the some application can change the FPGA image loaded. To load the FPGA image open a terminal on the RedPitaya and execute the following command: cat /opt/redpitaya/fpga/fpga_0.94.bit > /dev/xdevcfg"

Post Reply
jadalnie klasyczne ekskluzywne meble wypoczynkowe do salonu ekskluzywne meble tapicerowane ekskluzywne meble do sypialni ekskluzywne meble włoskie

Who is online

Users browsing this forum: No registered users and 6 guests